DBサーバ構築、Oracle 26ai(6)2ノードRAC構築 2

DBサーバ・Oracle RAC

Oracle DB構築(2ノードRAC)DB構築、プロファイル設定、サービス追加、アプリユーザ追加

DB構築

Oracle 21c(21.3.0.0)のDBCAではデフォルトの”orcl”以外のDB名を指定して先に進むと構築フェーズでASMディスク・グループにそのDB名のディスクが作成されずエラーとなりました。Oracle 26aiのDBCAだとこの問題は解決されている模様です。

ただしPDAの設定をいじることがができないのはこれまでのバージョンと同じなので、今回もDBCAで構築スクリプトを生成、これをよしなに修正・実行という段取りでDBを構築します。

事前準備

新DBサーバのCRSが停止している場合は新DBサーバ#1 -> 新DBサーバ#2の順にCRSを起動します。

DB構築スクリプト作成

GUIでDBCAを実行するので新DBサーバ#1のoracleユーザでVNC Serverを起動します。

作業PCのVNC Viewerで新DBサーバ#1にログイン、ターミナルを立ち上げて”dbca”と打ち込みDBCAを起動します。

DBCAを以下のように操作してDB構築スクリプトを生成します。

【DBCA操作手順】

No.画面操作
1データベース操作の選択「データベースの作成(C)」を選択
2データベース作成モードの選択「拡張構成(V)」を選択
3データベース・デプロイメント
・タイプの選択
データベース・タイプ(D):「Oracle Real Application Cluster(RAC)…(C)」を選択
データベース管理ポリシー(M):「自動」を選択
テンプレート名:「カスタム・データベース」を選択
4ノード・リストの選択prsdb01、prsdb02にチェックが入っていることを確認
5データベースIDの詳細の指定グローバル・データベース名(G):prdb
SID接頭辞(S):prdb
PDB用のローカルUNDO表領域の使用(L):チェック
「1つ以上のPDBを含むコンテナ・データベースの作成(A)」を選択
PDBの数(U):1
PDB名(P):prpdb
6データベース記憶域オプションの選択「データベース記憶域属性に次を使用(F)」選択
データベース・ファイルの記憶域タイプ(D):「自動ストレージ管理(ASM)」選択
データベース・ファイルの位置(L):+DG21/{DB_UNIQUE_NAME}
Oracle Managed Files(OMF)の使用(O):チェックしない
※OMFを使用しないことについての確認メッセージには「はい(Y)」クリック
7高速リカバリ・オプションの選択すべてチェックしない
8データベース・オプションの選択コンポーネント選択のチェックをすべて外す
9構成オプションの指定「メモリー(M)」タブ
—————————————————–
 「自動共有メモリー管理を使用(U)」を選択
 SGAサイズ(G):3584 MB
 PGAサイズ(P):1024 MB
—————————————————–

「サイズ設定(S)」タブ
—————————————————–
 ブロック・サイズ(L):8192
 処理(P):1000
10管理オプションの指定「クラスタ検証ユーティリティ(CVU)・チェックを定期的に実行(V)」のみチェック
(上記以外はチェックしない)
11データベース・ユーザー資格証明の指定「すべてのアカウントに同じ管理パスワードを使用(U)」選択
パスワード(P):<DB管理者パスワード>
パスワードの確認(C):<DB管理者パスワード>
12データベース作成オプションの選択「データベースの作成(C)」:チェックを外す
「データベース・テンプレートとして保存(T)」:チェックしない
「データベース:作成スクリプトの生成」:チェック
宛先ディレクトリ:{ORACLE_BASE}/admin/{DB_UNIQUE_NAME}/scripys
「記憶幾の場所のカスタマイズ」をクリック

「データベース作成オプションの選択」の「記憶幾の場所のカスタマイズ」をクリックすると「記憶域のカスタマイズ」画面が表示されます。スクリプト修正の手間を省くためここでDBの構成をざっくり編集します*1。編集内容は以下の通りです。

【記憶域のカスタマイズ画面操作】

No.設定対象設定内容
1Control Filesファイル名  パス
control01.cll +DG11/{DB_UNIQUE_NAME}/ctl/
control02.cll +DG11/{DB_UNIQUE_NAME}/ctl/
2SYSAUXファイル名:+DG21/{DB_UNIQUE_NAME}/dbf/sysaux01.dbf
※「オプション」タブ「BIGFAILE表領域の使用(M)」のチェックを外す
3SYSTEMファイル名:+DG21/{DB_UNIQUE_NAME}/dbf/system01.dbf
※「オプション」タブ「BIGFAILE表領域の使用(M)」のチェックを外す
4TEMPファイル名:+DG11/{DB_UNIQUE_NAME}/tmp/temp01.dbf
5UNDOTBS1ファイル名:+DG21/{DB_UNIQUE_NAME}/rbs/undotbs01.dbf
6UNDOTBS2ファイル名:+DG21/{DB_UNIQUE_NAME}/rbs/undotbs02.dbf
7USERSファイル名:+DG21/{DB_UNIQUE_NAME}/dbf/users01.dbf
※「オプション」タブ「BIGFAILE表領域の使用(M)」のチェックを外す
8Redo log Groups 11※Redo log Groups下の「1」をクリック
グループ番号(G):1 -> 11に変更
ファイルサイズ(H):204800KB -> 256 MBに変更
スレッド'(I):1
REDOログ・メンバー / ファイル名:
+DG11/{DB_UNIQUE_NAME}/log/redo11_1.log
+DG11/{DB_UNIQUE_NAME}/log/redo11_2.log (追加)
9Redo log Groups 12※Redo log Groups下の「2」をクリック
グループ番号(G):2 → 12に変更
ファイルサイズ(H):204800KB -> 256 MBに変更
スレッド'(I):1
REDOログ・メンバー / ファイル名:
+DG11/{DB_UNIQUE_NAME}/log/redo12_1.log
+DG11/{DB_UNIQUE_NAME}/log/redo12_2.log (追加)
10Redo log Groups 13※Redo log Groups → 「追加(B)」をクリック
グループ番号(G):13
ファイルサイズ(H):256 MB
スレッド'(I):1
REDOログ・メンバー / ファイル名:
+DG11/{DB_UNIQUE_NAME}/log/redo13_1.log
+DG11/{DB_UNIQUE_NAME}/log/redo13_2.log
11Redo log Groups 21※Redo log Groups下の「3」をクリック
グループ番号(G):3 → 21に変更
ファイルサイズ(H):204800KB -> 256 MBに変更
スレッド'(I):2
REDOログ・メンバー / ファイル名:
+DG11/{DB_UNIQUE_NAME}/log/redo21_1.log
+DG11/{DB_UNIQUE_NAME}/log/redo22_1.log (追加)
12Redo log Groups 22※Redo log Groups下の「4」をクリック
グループ番号(G):4 → 22に変更
ファイルサイズ(H):204800KB -> 256 MBに変更
スレッド'(I):2
REDOログ・メンバー / ファイル名:
+DG11/{DB_UNIQUE_NAME}/log/redo22_1.log
+DG11/{DB_UNIQUE_NAME}/log/redo22_2.log (追加)
13Redo log Groups 23※Redo log Groups → 「追加(B)」をクリック
グループ番号(G):23
ファイルサイズ(H):256 MB
スレッド'(I):2
REDOログ・メンバー / ファイル名:
+DG11/{DB_UNIQUE_NAME}/log/redo23_1.log
+DG11/{DB_UNIQUE_NAME}/log/redo23_.log
14–「OK(A)」クリック

「OK」をクリックすると「データベース作成オプションの選択」画面に戻るので「次へ(N)」をクリックして先に進みます。

次の「前提条件チェックの実行」画面では「HugePagesの有無」で警告が出ますがHugePagesはDB構築後に設定するので問題ありません*2。他にエラーや警告が出ていなければ「すべて無視」にチェックを入れて「次へ(N)」をクリックします。

サマリー画面でざっとDBの作成内容確認して問題がなければ「終了(F)」をクリックしてDB構築スクリプトを作成します。

*1:制御ファイルはパスの修正、データファイル&一時ファイルはパスの修正とBIGFILE指定の解除、REDOログはグループ番号、サイズ、パスの修正とグループ及びメンバ追加を実施します。DBCAでデータファイルや一時ファイルのサイズを修正(増加)してしまうとpdbseedのサイズも増加してしまうのでスクリプト側でCreate DB実行後にファイル・サイズの拡張を追加します。
なお、DBCAは制御ファイル・REDOログのパスに{DB_UNIQUE_NAME}、データファイル・制御ファイルのパスに”prdb”をそれぞれデフォルトで設定します。DBCAでファイル位置変数を確認すると{DB_UNIQUE_NAME}には”prdb”が設定されているので一見、どちらも同じに見えますが実際に生成されたスクリプトではDB_UNIQUE_NAMEが大文字の”PRDB”に置き換えられてしまいます。ASMは大文字/小文字を区別しないのでそのままDBを作ることはできますがOracle DB側ではファイル・パスの大文字/小文字はしっかり区別しているのでDB構築スクリプトに”prdb”と”PRDB”が混在していると後々トラブルの原因となりかねません。なのでデータファイル・制御ファイルのパスにある”prdb”はすべて{DB_UNIQUE_NAME}に置き換えます。しかし私、毎々思うんですけど、なんでこんな紛らわしいというか、トラブりそうな仕様にしているんですかね?

*2:事前にHugePagesを設定しておけばこの警告は出ないんでしょうけどマニュアル上はDB構築後にHugePagesを設定する流れになっているんですよね。その通りにやるなら毎回この警告が出てしまいます。紛らわしいんでマニュアルを直すかDBCAからHugePagesの確認を外すか、どっちでもいいんで紛らわしいことはやめて欲しいと心底思います。

DB構築スクリプトの編集と実行

DB構築スクリプトの編集

DBCAによって生成されたDB構築用スクリプトは /opt/app/oracle/prdb/scripts に格納されています。VNC Viewerだと操作が面倒なのでteratermでこのスクリプトを編集します。

DB構築スクリプト編集内容

以下、DB構築スクリプトの編集内容です。

なお、この編集は「DB構築スクリプトのコレとコレとコレのここをこう直す」といった感じOracleさんが公式手順的な的なものを出していてそれを参考にしたとかではなくDBCAで生成直後のスクリプト1本1本開いて確かめながら私の個人的見解でよしなにいじったものでございます。編集内容の裏付けとなる公式情報はなにもありませんのであしからず。

prdb1.sh(クリックで表示、編集箇所赤字表記)

シェル冒頭に記述された確認*1を差し替え、DB構築スクリプトの実行が失敗した場合のリラン対策*2とスクリプト一式のバックアップ(/home/oracle/にzipアーカイブ)、2番目のノード(prsdb02)のディレクトリ整備を追記します。

mkDir.sql(クリックで表示、編集箇所赤字表記)

ASMディスク・グループ”+DG11*3にprdbの親ディレクトリ(+DG11/PRDB)とPDB一時ファイル格納用のサブディレクトリ(+DG11/PRDB/prpdb)の作成を追加します。

prdb1.sql(クリックで表示、編集箇所赤字表記)

SQLスクリプト冒頭の管理者アカウントのパスワード入力をスクリプト内でのパスワードベタギリに変更、ついでにパスワード・ファイル作成コマンドにもパスワード指定を追加します。また、パスワード・ファイルのパスが+DG21となっているのでこれを+DG11に直し、クラスタ・リソースの依存先にDG11を追加します。

CreateDB.sql(クリックで表示、編集箇所赤字表記)

CREATE DATABASEコマンドに記述されたSYSTEM、SYSAUX、TEMP、UNDOTBS1のデータファイル NEXT(エクステント・サイズ)をすべて16Mに設定しなおします*4。

CreateDBFiles.sql(クリックで表示、編集箇所赤字表記)

CDBにUSER表領域と2番目のノードに割り当てるUNDO表領域が追加されるのでそのデータ・ファイルのサイズとエクステント・サイズを設計値に合わせて修正します。またCREATE DATABSEによって作成されたSYSTEM、SYSAUX、TEMP、UNDOTBS1のデータファイルも設計値の値にリサイズします。

postDBCreationl.sql(クリックで表示、編集箇所赤字表記)

SPファイルの出力場所を”+DG21″から”+DG11″に変更します。

plug_prpdb.sql(クリックで表示、編集箇所赤字表記)

PDB(prpdb)作成直後にローカル・ノードでPDBをオープン、セッションをPDBに移動して以下の処理を実行します。
・各表領域のデータ・ファイルを設計値に合わせてリサイズ
・prdb2で使用するUNDO表領域を作成
・各ノードへのUNDO表領域の割り当ての固定
また、Oracle 26aiのplug_prpdb.sqlではPDB用一時表領域の再作成が追加されています*5。新しく作成される一時表領域の属性を設計値に合わせて設定します。

postPDBCreation_prpdb.sql(クリックで表示、編集箇所赤字表記)

PDBのUSER表領域サイズを修正、USERTBL01表領域とUSERIDX01表領域を追加します。また、処理の最後にスクリプトによって作成したCDB,PDBの構成情報一式を出力するSQLを追記します。読まなくてもぜんぜん問題ない注釈

*1:昔からDBCAで作成したDB構築シェル(<インスタンス名>.sh)の冒頭には「スクリプトはすべてのリモートノードで実行されますか? 」という確認がついてます。私にはその質問の必要性がまったく理解できないのでどのDBバージョンのシェルでもバッサリ切り捨てていたんですが、Oracle21c版と同じようにOracle26ai版のシェルにもASMディスク上の既存ディレクトリ削除を組み込もうとして大事なことに気が付きました。
もしDB完成後に誤ってprdb1.sh実行してしまうと、この既存ディレクトリ削除によってせっかく作ったDBがASMディスクから消されてオシャカとなってしまいます。なので26aiのシェルではあのよくわからん確認を削除せず「スクリプトを実行すると既存リソースがあれば全部削除してDBを作成しますけど、実行しちゃっていいですか?」的な内容に差し替えてます。

*2:ぶっちゃけ、どのOracleバージョン、どのシステムだろうとDB構築スクリプトの修正が一発OKとなった記憶って私、ほとんどないんですよねぇ。修正一発目のシェル実行では怒涛の勢いでコマンド&エラーがteraterm画面上を流れて「あ、ミスった」で強制終了、画面をずーっと上までスクロールさせて起点となったエラーを確認・修正・リトライというのがお決まりのパターンです。で、そのリトライの前に毎度環境の復旧(Oracle21cの2ノードRAC構築におまけ的に書いた手順)をやるわけですが、これが地味に面倒くさい。復旧手順のやり漏れが原因でリトライ失敗、復旧手順をまた頭からやり直しなんてこともザラにございます。
そこで今回のOracle26aiのDB構築シェル編集ではシェル内に環境復旧処理を追加してみました。ただ、こうした緩急復旧をシェルに組み込むとDB完成後にprdb1.shを誤実行した場合悲惨な結果になってしまいます。一応、シェル誤実行の防止としてprdb1.shの冒頭にこのシェルを実行するとどうなるかを説明の上、やるやらないの確認を入れましたが世の中にはシェルを誤実行しているクセにここを突破するヤツっているんですよ。そこで環境復旧作業のひとつ、「DBバックグラウンド・プロセス停止」については実際の停止までやらずその前段のプロセス・チェックまで。チェックに引っかかった場合は停止コマンドを表示はしますがそれを実行するかどうかは人間の判断としています。シェルを誤実行して手動でDBの停止まですることはさすがにないかなと。つまりは起動中のDBバック・グラウンド・プロセスを手動停止にしたのはここが最終防衛ラインということです。

*3:DBCAの「記憶域のカスタマイズ」画面で「データベース記憶域オプションの選択」の指定と異なるディスク・グループにサブディレクトリをつけてファイル・パスを設定すると、mkDir.sqlにはそのディスク・グループに親ディレクトリを作成せずいきなりサブディレクトリを作成するコマンドが出力されてしまいます。このままmkDir.sqlを実行すればそのディスク・グループのディレクトリ作成は軒並みエラーとなって後続のDBの作成は失敗してしまいます。なのでmkDir.sqlには対象ディスクグループに対する親ディレクトリ(とPDBの一時ファイル格納用ディレクトリ)の作成を追加しなきゃならないわけですけど、この挙動って以前のバージョンでも同じなんですよね。ぼちぼち直してくれんかな。

*4:CDB各表領域のデータ・ファイルに設定されたエクステント属性はpdbseed -> PDBへと継承されるのでCreate Databaseのタイミングで設定しておきます。なお、ここでデータ・ファイルのサイズも設計値に合わせて設定してしまうとCDBをベースに作られるpdbseedのサイズも増加してしまいます。
まあ、CDBの設計値はそれほど大きなものではなく、またCDBの縮小サイズでpdbseedが作成されるのでpdbseedがやたらとでかくなってしまうようなことはないんですが、pdbseedってPDBの元ネタ以外に使い道がないですよね。わずかとはいえそれで余分な領域を食うのはうれしくないので一旦、小さなデータ・ファイル・サイズ(DBCAのデフォルト設定サイズ)でCDB、pdbseedを作成、次に実行するCreateDBFiles.sqlの中でデータ・ファイルをリサイズしようと思います。

*5:Oracle 21cのplug_prpdb.sqlでは”CREATE PLUGGABLE DATABASE”コマンドで一時表領域を作成したらそれっきりだったんですがOracle 26aiのplug_prpdb.sqlだとPDB作成後にわざわざ新しい一時表領域を追加してpdbseedから作成した一時表領域を再作成(Drop&Create)しています。なんでこんな面倒なことをやっているんですかね? まったく分かりません。
そういえばOracle 21cの”CREATE PLUGGABLE DATABASE”だとfile_name_convertによる一時ファイルのパス変換でマニュアル通りの指定順(優先的にやりたい一時ファイルのパス変換を先)では上手くいかず、逆の指定順(一時ファイルのパス変換を後)だと変換できた、なんてことがありました。Geminiさんによれば一時ファイル作成の仕様(他のデータファイルと違ってseedからのコピーではなくPDBオープンのタイミングで作られる)が関係しているんじゃないかと。Oracle 26aiでPDBの一時表領域を再作成するようになったのもそうしたことが絡んでいるんでしょうかね。

DB構築スクリプトの実行

DB構築スクリプトの編集が終わったらprdb1.shを実行します。

このスクリプトの実行によってprdbの構築を行う旨、また既存のprdb関連オブジェクトがあればすべて削除するという説明に続けて実行するかどうかの確認が表示されます。”Y”を入力、Enterキー押下でDBの構築を開始します。

prdb1.shの実行を開始してからしばらくの間エラーメッセージが表示されず、Create Dabatabse後にスクリプトの処理が程度ゆっくり進行し始めたらとりあえずまともに動いているので後はプロンプトが戻されるまでの小一時間、そのまま放置します。

すべての処理が終了してプロンプトが戻されたらprdb1.sh実行時点まで出力メッセージを遡り途中でエラーが出ていないことを確認します。DBINFO.logにCDB、PDBの設定内容が出力されているので内容を確認して設計通りであればOK、DBの(ガラの)構築はひとまず完了です。

ORACLE_SID設定

oracleユーザの.bash_prfile(home/oracle.bash_profile)に ORACLE_SIDを設定します。

【新DBサーバ・ORACLE_SID設定】

対象サーバ対象ファイル設定値
prsdb01/home/oracle/.bash_profileexport ORACLE_SID=prdb1
prsdb02/home/oracle/.bash_profileexport ORACLE_SID=prdb2

rootからoracleユーザにスイッチしている場合は一旦抜けて再ログインするなど、oracleユーザの環境変数を最新の状態にしてから内部接続(リスナーを経由しない接続)でDBにログインできることを確認します。

【新DBサーバ・prsdb01、prsdb02 / oracleユーザで実行】
-----------------------------------------------------------------------------
# sqlplusでPRDBに接続
sqlplus / as sysdba

select instance_name from V$INSTANCE;
-- ORACLE_SIDと同じインスタンス名が返されることを確認

exit

デフォルト・プロファイル設定

Oracle DBのデフォルト・プロファイルに設定されているPASSWORD_LIFE_TIME(パスワード有効期限)は 180日です。個人ユーザならともかくシステム・ユーザやアプリケーション・ユーザのパスワードが期限切れになったらマジ洒落にならないのでデフォルト・プロファイルの無制限に変更します。

なお、CDBとPDBではプロファイルが別々です。そのためCDBのデフォルト・プロファイルを設定を変更したらPDBでも同じ作業を繰り返します。

【新DBサーバ・prsdb01 / oracleユーザで実行】
-----------------------------------------------------------------------------
# sqlplusでPRDBに接続
sqlplus / as sysdba

-- CDBで現在のデフォルト・プロファイルの設定を確認
col LIMIT format a20
set pages 999
select RESOURCE_NAME,LIMIT from DBA_PROFILES where PROFILE = 'DEFAULT';


-- CDBでデフォルト・プロファイルのPASSWORD_LIFE_TIME を無期限に変更
ALTER PROFILE DEFAULT LIMIT PASSWORD_LIFE_TIME UNLIMITED;

-- 設定変更後のデフォルト・プロファイルの設定を確認
select RESOURCE_NAME,LIMIT from DBA_PROFILES where PROFILE = 'DEFAULT';

-- セッションをPDBに移動
alter session set container = PRPDB;

-- PDBで現在のデフォルト・プロファイルの設定を確認
select RESOURCE_NAME,LIMIT from DBA_PROFILES where PROFILE = 'DEFAULT';

-- PDBでデフォルト・プロファイルのPASSWORD_LIFE_TIME を無期限に変更
ALTER PROFILE DEFAULT LIMIT PASSWORD_LIFE_TIME UNLIMITED;

-- 設定変更後のデフォルト・プロファイルの設定を確認
select RESOURCE_NAME,LIMIT from DBA_PROFILES where PROFILE = 'DEFAULT';

exit

DBサービス作成

アプリケーションからの接続に使用する DBサービスを追加します。

サービスはオンライン・アプリケーション接続用、バッチ・アプリケーション接続用の2種類を作成する想定です。しかしバッチ・アプリケーション接続用サービスのプライマリ・ノード(新DBサーバ#3)はまだRACに追加していません。なのでここではオンライン・アプリケーション接続用サービスのみ作成します。

【新DBサーバ・prsdb01 / oracleユーザで実行】
-----------------------------------------------------------------------------
# オンライン・アプリケーション接続用サービス追加(1行で記述)
srvctl add service -database prdb -service online_srv -pdb prpdb -preferred prdb1,prdb2 -failback NO -tafpolicy BASIC -policy AUTOMATIC -notification TRUE -clbgoal SHORT -failovertype SESSION -rlbgoal SERVICE_TIME -failoverretry 3 -failoverdelay 5

# オンライン・アプリケーション接続用サービスを起動
srvctl start service -db prdb -service online_srv

# オンライン・アプリケーション接続用サービスの状態を確認
srvctl status service -db prdb -service online_srv

# オンライン・アプリケーション接続用サービスの設定を確認
srvctl config service -db prdb -service online_srv

# prdb1/online_srv接続確認(1行で記述、パスワード要求には共通の管理者パスワード*を入力)
sqlplus pdbadmin@(DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = prsdb01)(PORT = 1521)))(CONNECT_DATA = (SERVICE_NAME = online_srv)))

-- SQL*Plus終了
exit

# prdb2/online_srv接続確認(1行で記述、パスワード要求には共通の管理者パスワード*を入力)
sqlplus pdbadmin@(DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = prsdb02)(PORT = 1521)))(CONNECT_DATA = (SERVICE_NAME = online_srv)))

-- SQL*Plus終了
exit

*:共通の管理者パスワードはDB構築スクリプト(prdb1.sql)の”define sysPassword”にベタギリしたアレです。

現行DBだとアプリ用のアプリ用のユーザ作成はSYSで全部やってしまいましたが折角、OracleがPDBの管理者を用意してくれているのにこれを使わないのはどうなのよ、ということでPDBADMINに管理者権限を付与してこのアカウントでアプリ用ユーザを追加しようと思います。

まずはPDBADMINに付与されている権限を確認。

で、このPDB_DBAの中身はというと

PDB_DBAにはいくつか権限は付与されていますがこれだけではPDBADMINにPDB内の管理を任せるには足りません。なのでDBAロールを追加付与します。

これでPDBADMINは一通りの管理作業ができるようになりました。PDBADMINでPDBに接続*2しなおして追加ユーザの作成を行います。

*1:DBAをPDBADMINに直接付与するかPDB_DBAロールに付与するかで迷いましたがGeminiさんに相談したら「権限の最小特権の原則と影響範囲の限定」、「監査と可視性の向上」、「Oracle標準の設計思想への合致」の三点を考慮してPDBADMINに直接付与した方がよろしかろうということでこの設定となりました。

*2:ここまで書いてようやく気付きましたが先にOracle Netサービスを作成してからユーザ関連の設定をやるべきでした。Oracle Netサービスが無いと簡易接続の指定を長々と書かなきゃならないんで面倒です。まあ、今更作業の順番を入れ替えるのもそれはそれで面倒なのでやりませんけども。

ちょっと長くなったんで一旦ここまで。次はアーカイブログ設定、バックアップ設定、HugePages設定、Oracle Netサービス作成です。

DBサーバ構築(Oracle 26ai)・関連ページ
DBサーバ構築、Oracle 26ai(1)概要
DBサーバ構築、Oracle 26ai(2)OS、N/W、ストレージ
DBサーバ構築、Oracle 26ai(3)Gridインストール1
DBサーバ構築、Oracle 26ai(4)Gridインストール2
DBサーバ構築、Oracle 26ai(5)DBインストール
DBサーバ構築、Oracle 26ai(6)2ノードRAC構築 1 (DB設計)
DBサーバ構築、Oracle 26ai(6)2ノードRAC構築 2 (DB構築)

メニュー

トップページ

3層Webシステム | バカメのとなり

投稿一覧

過去投稿一覧

自己紹介

タイトルの由来と自己紹介 | バカメのとなり

ぎゃらりい | バカメのとなり

問合せ(メール)

お問い合わせ | バカメのとなり

コメント

タイトルとURLをコピーしました